Scheduled task not running

More
7 years 8 months ago #227 by Simonson
In ADReporter I can schedule a task with my account which is a domain administrator and it runs. When I use a different account which is also a domain administrator to run the scheduled task it does not run. Why? When scheduling tasks our practice is to not use our own accounts.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #228 by JavelinaWade
Hi Simonson,

Normally, this issue occurs because the product has not been registered for the user that is attempting to run the task. Log on to the machine in question with the 2nd account, launch ADreporter, and select the Register option from the File menu (the AD orb in the upper left corner). After re-entering your registration info there, give the task another go to see if it'll run correctly.

If that doesn't work, let me know and we'll take a look at your log files to find out exactly what's going on.

-Wade
The following user(s) said Thank You: JayGriffin

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #231 by Simonson
Replied by Simonson on topic Scheduled task not running
Signed in with the other account and scheduled task still did not work. Added the account as local admin on the servers and it worked. Would prefer not to have the account as a local admin. If there is a way to run the schedule task without local admin access please let me know. Thanks for your help.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #232 by JavelinaWade
Hmm, I've created a couple test users with no special permissions (not local Administrators, etc) in our test environment here and I'm not seeing the same behavior. From some research online, it looks like the one vital permission required to run tasks is "Log on as a batch job", which is assigned to the local Administrators group by default. If your user has not been assigned that security setting, you can modify it using the Local Security Policy administrative tool (screenshot attached) or via GPMC.
Attachments:

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #235 by Simonson
Replied by Simonson on topic Scheduled task not running
Just a FYI... yes - prior to adding the account as local admin on all servers the account had the permissions ' log on as a batch job. Thanks for your help.

Please Log in or Create an account to join the conversation.

Time to create page: 0.140 seconds